Start a new topic

Browser versions

What browsers and versions are supported by the explorer?


You should get a warning like this if you have too old browser:

The Open PHACTS Explorer is designed to work with modern html5 and
CSS3 enabled browsers such as Chrome, Firefox, Opera and Internet Explorer 10 or higher.

Using an older browser may lead to a sub-standard experience and in some cases may not work at all

The chances are that a lot of the application will work as far back as IE6 & IE8  but we no longer test it on those browsers. Many of the features which use HTML5 aspects such as IndexedDB, for example the 'favouriting' will not work. To get the full explorer experience you need to use a modern browser such as IE10/11, Firefox 35+, Chrome 31+, Safari 7.1+ & Opera 27+.

Login or Signup to post a comment